System Requirements

General Requirements

In addition to having the latest web browser, there are a few other requirements below that will help ensure your course experience goes smoothly. Please make sure your desktop/device has the following:

  • One of the web browser versions listed below
  • Javascript enabled
  • PDF plugin
  • Graphic and audio output capability
  • Broadband internet connection with a minimum speed of 5Mbps (recommended)
  • TLS 1.2 supported by your web browser
  • Privacy or cookie-blocking software paused


Supported Desktop Web Browsers

  • Firefox
  • Safari
  • Chrome
  • Edge


Supported Mobile Browsers

  • iOS Safari: 11 and up
  • Chrome
  • Samsung Internet


We currently support the latest two versions of all browsers listed above, unless otherwise noted. While we support all of the browsers listed above, we recommend using Chrome or Firefox on a desktop for best results while taking your courses. 

Note that we do not support Internet Explorer.